Newcomer / Intro Newbie, I need help to Insert New Bindings In ED

Just new to the game and have bought a Thrustmaster 16000 Hotas set. I am not familiar with the complexities of setting binds that might be needed to really enjoy the game on a better level.

I was glad to find TMster Hotas preset, that got me playing and learning the game. But now I'd like to be a bit more adventurous.

And I am a newbie. I mostly played FPS in BF and some Arma( I Am a senior Citizen). But this game brought me back to my Commodore 64 era

I have seen a very nice kind of complete bind that would work for me. This one in the link: https://edrefcard.info/configs/uwtpew.binds

I have downloaded it and I'd like to insert it in my ED binds. I see it is an XML file so when I downloaded it came in an XML doc. I opened it with Notepad++and it's huge.

Now when I go into ED Local /options/ Bindings; it shows me this notepad file StartPreset, when I open it I find this: T16000MHOTAS. nothing else. It is very tiny compared to the binds I want to use, https://edrefcard.info/configs/uwtpew.binds that file is huge.

My question is how do I import the uwtpew.binds into the Bindings file in ED. ?


I do really need a step by step help if anyone is kind enough to guide me through it, I 'd be really appreciative.

Thanks in advance

Shal



 
The StartPreset file just shows Elite which set of bindings to use.
Somewhere in that same folder you've probably got a file called T16000MHOTAS.binds

That's the one you need to replace.
Just save a copy of it somewhere else. Delete the original then paste in a copy of your new binds file and rename it T16000MHOTAS.binds

If it doesn't work just copy the original back into the folder.

Version 2 - alternative.

Paste your file uwtpew.binds into the folder and change the text in the StartPreset file to read uwtpew instead of T16000MHOTAS and save it.
 
Last edited:
The default preset you chose (T16000MHOTAS) resides in a different location to the directory you looked in (as do the other preset ones that come with the game).

The downloaded file from EDRefCard site ( in your case uwtpew.binds ) should be placed in your binds directory:

%LOCALAPPDATA%\Frontier Developments\Elite Dangerous\Options\Bindings

N.B. Download the file with "save as" - don't open the file in your browser and try to save it as that can give problems.

... This will show up in your drop-down menu as "custom" as that is what is listed in the file. I would strongly urge you to change that <Root PresetName="Custom" in the file to something else as the custom binds file is the one that the game overwrites - hence you see people complaining about losing their bindings. So I would say change the file name to SOMENAME.binds and the Root PresetName to be also SOMENAME and thus you have your own protected binds file.

Secondly - do not keep copies in the same directory, even renaming them doesn't help as the game looks for <Root PresetName= in every file so duplicates cause problems - notably changes not being saved.

P.S. Don't worry about the "SatrtPreset" file - that gets changed by the game after you select your controls from the drop-down list - there is no need to edit it yourself.
 
Last edited:
The StartPreset file just shows Elite which set of bindings to use.
Somewhere in that same folder you've probably got a file called T16000MHOTAS.binds

That's the one you need to replace.
Just save a copy of it somewhere else. Delete the original then paste in a copy of your new binds file and rename it T16000MHOTAS.binds

If it doesn't work just copy the original back into the folder.

Version 2 - alternative.

Paste your file uwtpew.binds into the folder and change the text in the StartPreset file to read uwtpew instead of T16000MHOTAS and save it.
Don't do any of that - it is wrong.
 
Why is it wrong ?
Why can't you replace files in the presets folder?

He said he wanted an easy way to do it.
1 - The <Root PresetName would not match the file name of the preset you suggest pasting the content into, therefore the startpreset would be incorrect.

2 - The <Root PresetName would not match the file name "uwtpew" and so the startpreset would be incorrect.

The game looks for the name given by the <Root PresetName so you need to bear that in mind when giving anyone instructions. In both your cases the game would see the <Root PresetName="Custom" in that binds file from EDRefCard.
 
I appreciate your help, but now I'm confused. What is the proper way to do it? ParaHandy could you give me the proper way ? As you seem to think that Maenden was mistaken?

I have copied and saved mY Preset Hotas Notepad file in differnt place. NOw how do I rename mY new bindings from uwtpew . Do I insert the new file w ith that name instead of custom or what is the procedure?
 
Simplest is to open the downloaded binds file (I use notepad) and change the name in line 2 of the file <Root PresetName= to a name other than custom e.g. Shaldag01 (as custom.binds file can get overwritten by the game at times, notably on updates) - this is the name that you will see in the drop-down list in the Options/Controls page. Now rename the actual file to Shaldag01.binds (or whatever name you want) then copy that into your Options/Binds folder located at

%LOCALAPPDATA%\Frontier Developments\Elite Dangerous\Options\Bindings

Start the game, select Options then Controls then from the drop-down list of presets you select Shaldag01 (or whatever you called it in line 2 of the file) et voilà - done. Now changes you make in that page will be saved in that binds file when you select "apply".

HOWEVER - This 3.4 update might change some of this.
 
yep thanks ill see what happen and keep yu posted , thanks fopr your help
Good luck.

Couple other points - you may need to change the keyboard setting to suit yours, the file you referenced has the line:

<KeyboardLayout>en-US</KeyboardLayout>

you might need / want to change that to:

<KeyboardLayout>en-GB</KeyboardLayout>

... or whatever.

Finally - I have to confess I have no idea what the class="mozwebext" means in your referenced file, I have never seen that and I have no entry with class in line 2 of any binds file - if you have some issues then just delete that from line 2 of the file.
 
1 - The <Root PresetName would not match the file name of the preset you suggest
I understand what you mean.
I'd forgotten about that bit.

But surely all he needs to do is edit the word "Custom" in the file to read "T16000MHOTAS"

So replace
<Root PresetName="Custom" MajorVersion="3" MinorVersion="0">

With

<Root PresetName="T16000MHOTAS" MajorVersion="3" MinorVersion="0">"

I can't find class="mozwebext" in his file.
Perhaps your text editor did that?

Perhaps he also needs to add the header?

<?xml version="1.0" encoding="UTF-8" ?>
 
I understand what you mean.
I'd forgotten about that bit.

But surely all he needs to do is edit the word "Custom" in the file to read "T16000MHOTAS"

So replace
<Root PresetName="Custom" MajorVersion="3" MinorVersion="0">

With

<Root PresetName="T16000MHOTAS" MajorVersion="3" MinorVersion="0">"

I can't find class="mozwebext" in his file.
Perhaps your text editor did that?

Perhaps he also needs to add the header?

<?xml version="1.0" encoding="UTF-8" ?>
1. Yes indeed they could do that. I don't think doing it in the presets directory is a good option though, I think it best to get to grips with the Options directories right away.

2. I had actually just opened the OP's link in a browser and of course that striped the top line and stuck in that "class" for some reason. When I followed my own advice and did a "save as" and opened it, sure enough the "class" wasn't present...

3. ... but the <?xml version="1.0" encoding="UTF-8" ?> line was present.
 
Nothing works I have my new bind file listed as Shaldag1 with the new bindings, but i cannot get rid of tehhSatratFile, I delete T16000MHOTAS Inside, but it gets re written every time.
I must be doing something quite wrongly.
 
Nothing works I have my new bind file listed as Shaldag1 with the new bindings, but i cannot get rid of tehhSatratFile, I delete T16000MHOTAS Inside, but it gets re written every time.
I must be doing something quite wrongly.
Do you mean the "StartPreset.start" file? That should be overwritten when you select Shaldag1 in your Options/Controls settings page and select Apply. ( I wonder if there is an issue with the downloaded binds file being incompatable with your setup.)

OK - so assuming that in your Options/Bindings directory you have now got your Shaldag1.binds file and that the name inside that file (<Root PresetName) has been changed to Shaldag1 then you can edit the StartPreset.start to read Shaldag1. However, there might be an error with the binds file and that is giving you an issue, so:

In the Bindings directory there will be a file called BindingLoadingErrors.log - what does that say?

... also did you change the KeyboardLayout I mentioned in post #10?

If you are still having issues - can you select your T16000MHOTAS preset, change an entry in one (or some) of the controls and select "Apply"? That should create a "custom" binds file and we can see if your StartPreset.start file updates to show that.

P.S. I was disappointed to see that the update still has not added a "Save As" option in the Controls page - I really can't understand why they have not done this.
 
Last edited:
It must be the bindings I have downloaded. Must have made a mistake doing it.
I went back and redownloaded the original new bindings and imported it into the bind file it shows now as Shaldag 1 in my Controls menu in game. I 'll try it and see what happens.
Thanks very much for your help
 
Top Bottom