EDDiscovery - Exploration Tool for PC Users. Journal, 3dMap, Voice

I have noticed an increased frequency of late of EDD apparently locking up & not responding for a while, but it hasn’t seemed to affect ED. Either it eventually wakes up or I kill the process and restart.

What I have most definitely noticed during DW2 is that when typing in a comment against a system the cursor keeps jumping to the very left of the text box so I end up with nonsense. I thought it was me hitting a control key combination to reset the cursor position, but I think it’s EDD itself
This sounds like my problem.

ED isn't affected, my system can cope OK, EDD just grinds to a halt. I have used Task Manager to raise the priority of EDD but nothing changed.
Even just starting EDD and waiting for the history to populate (only a few days since last dock) takes much longer than it used to.
Plus my records on EDSM are not updating correctly.
All very odd :confused:
 
I have noticed an increased frequency of late of EDD apparently locking up & not responding for a while, but it hasn’t seemed to affect ED. Either it eventually wakes up or I kill the process and restart.
Yes, it becomes very busy and it was affecting ED performance, hence the batch file. At least now it's busy on its own.
 
Our problem is wanting to sort out EDD - ED runs happily
I am running out of ideas now
Have you tried reducing the number of journal entries held in memory?

I've got it set to only load essential entries more than 30 days old, with the 'Essential Entries Are' dropdown set to 'All Entries For Statistics' and that's fine with around 100-150k of 600k journals loaded at any point in time.
 
Have you tried reducing the number of journal entries held in memory?

I've got it set to only load essential entries more than 30 days old, with the 'Essential Entries Are' dropdown set to 'All Entries For Statistics' and that's fine with around 100-150k of 600k journals loaded at any point in time.
Thank you :) I will try that. I can see it may help load times.
Any idea why my EDSM data should be wrong? EDD shows around 450 jumps in past 4 days, but EDSM less than half that :rolleyes:
 
Have you tried reducing the number of journal entries held in memory?

I've got it set to only load essential entries more than 30 days old, with the 'Essential Entries Are' dropdown set to 'All Entries For Statistics' and that's fine with around 100-150k of 600k journals loaded at any point in time.
Thank you, I did that. Before, EDD was occupying 10GB of memory! Now it's down to 250Mb!
 
Thank you :) I will try that. I can see it may help load times.
Any idea why my EDSM data should be wrong? EDD shows around 450 jumps in past 4 days, but EDSM less than half that :rolleyes:
I think sometimes if EDD is hung, crashed, or not running, or if there's some sort of network issue (anywhere between you and EDSM), some jumps may not get reported properly. It can usually be fixed by manually uploading all of the journals for whatever time period to EDSM, which will allow it to find the jump entries that are missing.
 
Any idea why my EDSM data should be wrong? EDD shows around 450 jumps in past 4 days, but EDSM less than half that :rolleyes:
It's the internet, things get lost and we don't do much automatic retrying. Entries are only marked as sent if we get a positive acknowledgement from EDSM so syncing again should retry anything that didn't get through. If you try that and it says everything has been sent but it's still missing from EDSM let us know.
 
I think sometimes if EDD is hung, crashed, or not running, or if there's some sort of network issue (anywhere between you and EDSM), some jumps may not get reported properly. It can usually be fixed by manually uploading all of the journals for whatever time period to EDSM, which will allow it to find the jump entries that are missing.
It's the internet, things get lost and we don't do much automatic retrying. Entries are only marked as sent if we get a positive acknowledgement from EDSM so syncing again should retry anything that didn't get through. If you try that and it says everything has been sent but it's still missing from EDSM let us know.
Thanks both of you.
Everything now runs quicker and EDD didn't lock up for a 30min session, so all good there :)
I am just syncing now (it all seems to be downloads from EDSM rather than uploads) and I will go through the past few days to check the data.
Thanks again; EDD is a great tool for us to use :cool:

OK
did a sync, but there is at least one (and I suspect other) gap which did not get to EDSM


There is a gap of 3,500Ly


Am I syncing correctly:
Admin\synchronise with EDSM ...\ fetch logs again does nothing (looking at the log pop-out); \fetch star data again, re-downloads all the EDSM star data
Am I missing something...?
 
Last edited:
Thanks both of you.
Everything now runs quicker and EDD didn't lock up for a 30min session, so all good there :)
I am just syncing now (it all seems to be downloads from EDSM rather than uploads) and I will go through the past few days to check the data.
Thanks again; EDD is a great tool for us to use :cool:

OK
did a sync, but there is at least one (and I suspect other) gap which did not get to EDSM


There is a gap of 3,500Ly


Am I syncing correctly:
Admin\synchronise with EDSM ...\ fetch logs again does nothing (looking at the log pop-out); \fetch star data again, re-downloads all the EDSM star data
Am I missing something...?
In settings do you have sync both to and from EDSM ticked?
 
Am I syncing correctly:
Admin\synchronise with EDSM ...\ fetch logs again does nothing (looking at the log pop-out); \fetch star data again, re-downloads all the EDSM star data
Am I missing something...?
You're missing the EDSM button in the ribbon (6th control from the left in the bar with the Commander drop down). That's the one that'll retry any logs that haven't been flagged as getting to EDSM successfully.
 
You're missing the EDSM button in the ribbon (6th control from the left in the bar with the Commander drop down). That's the one that'll retry any logs that haven't been flagged as getting to EDSM successfully.
Thank you - Again :)
It is currently at 8200 and counting - will it re-send all 70+ thousand???

Edit
It sent 17340 but I don't think there were that many 'lost' entries. looking at my EDSM profile I can see that several 'blank' days have been filled - so all done I think.
THANK YOU :D
 
Last edited:
It sent 17340 but I don't think there were that many 'lost' entries. looking at my EDSM profile I can see that several 'blank' days have been filled - so all done I think.
THANK YOU :D
EDSM takes most of the notable journals, not just the travel stuff, so all the engineering, material pick ups, load out and other stuff at log on, mission related stuff, etc etc. The actual travel history bit is an every decreasing fraction of what ED records in the journals these days (hence the ever increasing volume of stuff and need to have options to not keep the non-essential bits loaded). For every jump you noticed was missing on EDSM there could be dozens of other journals that didn't get through for whatever reason that don't impact on travel history.
 
Is 10.6.1 still due out soon?
Started but failed to download 10.6 last night, then thought what the heck with the update imminent
 
Last edited:
I seem to miss something. About a year ago I made my "Palin run", in the end 773 jumps and 4015 bodies scanned. With EDD I created two exports, one just listing all the jumps, the other listing all the scanned bodies, with all details of the bodies w.r.t. type, value, composition, materials, … all in separate columns (see screenshot).
Right now I am on a longer trip through Formidine Rift, Elysian Shores, Vulcan Gate, and intent to make it to Colonia sooner or later. I am now at >2k jumps/>18k scans and tried to look up some statistics again. The jump list I could create by filtering the history tab alright, but I seem to be unable to create an extract for the scan data?! Can't find a add-on/filter options to get the data in a suitable format like before. I guess I just didn't search properly?!?!
scan_extract.PNG
 
You need to do an export from the Scan panel (the Excel icon, pops up a dialog with date ranges, options to export everything or just stars, just planets etc.)
Great, thanks!
Noticed that it has two entries for the same body, I think one each for FSS scan and mapping (same entries with different timestamp, I think). I guess I can handle that….
 
Has anyone else noticed the problem with the cursor jumping back to initial position when part way through typing in a comment note, leading to gibberish, or is it just me being clumsy?
 
Top Bottom