Cannot Update Launcher On Steam

I have the same issue with the steam version. Started on tuesday I think.
The strange thing is, I can manually start the launcher from the installation folder. So obviously the launcher has alrerady updated.
 
The steam auto-login can be disabled by renaming the file "steam_api64.dll" to something else, e.g. "steam_api64.dll.switched_off"
The file resides in (or similar to)
c:\Program Files (x86)\Steam\steamapps\common\Elite Dangerous\
There are probably unwanted side effects which I could not yet examine, but it is easily renamed back.
And it is not permanent, with the next update it will reappear.
 
The steam auto-login can be disabled by renaming the file "steam_api64.dll" to something else, e.g. "steam_api64.dll.switched_off"
The file resides in (or similar to)
c:\Program Files (x86)\Steam\steamapps\common\Elite Dangerous\
There are probably unwanted side effects which I could not yet examine, but it is easily renamed back.
And it is not permanent, with the next update it will reappear.
How the hell do you find out these things????????? Damned thing is all machine language.
And yeah, not comfortable with unexpected side effects glitching things.
BTW, this file shows last updated April 15 (which is when this issue started).

Putting Steam in offline mode works also against auto-login (seems to be obvious)
THIS works. Thank you! (y) Have a 🍺
 
Last edited:
I also have the same issue. "Update Required - Close Launcher". I hope this is fixed soon as it is very frustrating
 
After
Steam -> Library -> Elite Dangerous -> Properties -> Local Files -> Verify Integrity...
it found some errors and downloaded 1.5 GB of updates
But afterwards the Issues is exactly the same as described earlier in this thread:

The Steam dialog after clicking on "Play" and choosing from the options starts the launcher with different command line options:
If you choose
1) Play Elite Dangerous
the launcher is started as:
"C:\Program Files (x86)\Steam\steamapps\common\Elite Dangerous\EDLaunch.exe" /Steam /novr

Choosing
2) Play Elite Dangerous: Horizons
the command line is
"C:\Program Files (x86)\Steam\steamapps\common\Elite Dangerous\EDlaunch.exe" /EDH /steamid 4XXXX0 /novr

Starting the Launcher from a windows cmd line with
"C:\Program Files (x86)\Steam\steamapps\common\Elite Dangerous\EDlaunch.exe" /EDH /novr
lets me log into manually but it requires a Verification code which is send by email.

If I run the 1) cmd line:
"C:\Program Files (x86)\Steam\steamapps\common\Elite Dangerous\EDLaunch.exe" /Steam /novr
it starts the launcher fine, but AFTER login the "Update Required" -> "Close Launcher" Login appears.
So it is not the Launcher, which has some issue, but it is something connected to the login procedure if you have "Horizons" but running the launcher in some kind of "non-horizon" mode without the "/EDH" option.

I think I am opening an issue, but hesitating going through this hazzle.
 
Last edited:
It's obviously not a Steam only issue, as I face exactly the same problem on my Windows version. It occurred after having installed the new launcher. I can till start the game, but all the information in the launcher is replaced by a 404 error page.
 
I don't have the 404 issue, this seems to be another, maybe independent, issue. Someone else must investigate as I can't see it.
 
This leads to another solution which I just thought of:
Just add /EDH to the Launch options in steam
Steam -> Library -> Elite Dangerous -> Properties -> General -> Set Launch Options
/EDH

Works, but obviously, you can't run a non Horizons ED anymore. Which is bad if you are stuck somehow with your SRV or in some planetary graphics glitch. Starting non horizons ED solved this before.
 
Same for me. No idea how it saved my password but it comes up as "go ahead and hit play, I've already put your password in for ya" and no way to undo this. Tried logging out of the launcher and then hitting "log-in" again, asks for the log-in id and P/W (and I make sure the "remember P/W" is unchecked) but it still remembers it the next time I fire it up from the Steam PLAY button. I do prefer...security.
I was able to fix this in two ways. Your browser will store your credentials. Delete the credentials stored in the browser.
I think in steam you can link the two together.
 
Last edited:
I was able to fix this in two ways. Your browser will store your credentials. Delete the credentials stored in the browser.
I think in steam you can link the two together.
Actually, check the research done by RexKraemer, he's been doing a lot of really good ground work in figuring out the "auto login" feature and suggested that if you start Steam in the OFF-LINE mode, THEN start ED, you'll get the normal log-in screen asking for your P/W. So, something is broken and it's not you or me.
 
My issue is I cannot choose the original Elite Dangerous, it shows Install and the button is disabled. I checked all the account settings and linked all the keys and still no change. Only use it to switch the mission boards but it would have been really nice for FDev to announce this update and TEST IT BEFORE implementing it! Not looking forward to Wednesday's update as I'm sure it will be full of bugs.
 
By original you mean elite dangerous without horizon? In this case I guess its currently not working, you can't login for non-horizons ED. I didn't found a way to start a working launcher for ED without horizon.
 
As far as I can tell you can't get the normal version of ED to work in Steam, only Horizons and VR as they start on a separate load iirc. It's just annoying as hell and reinstalling doesn't fix the problem.
 
Another variation to go which solves all issues for me:

Close Steam and run EDLauncher from a command line without any options:
"C:\Program Files (x86)\Steam\steamapps\common\Elite Dangerous\EDlaunch.exe"
After login you see what we were used to. A Launcher with choice EDH, ED, ED Arena and Single Player Combat Training next to the Play Button field.

Now if I choose ED (non horizon) the "Play" Button text changes to "Upgrade". So doing the upgrade.
After the upgrade I can choose ED (non-horizon) to Play.

Close ED and back to Steam:
Starting ED from Library (remove this extra option /EDH if you have added it as described above) brings up the choice dialog, choosing
1) Play Elite Dangerous
brings back the old behaviour, no auto login, choices next to Play

2) Play Elite Dangerous: Horizons
no choices, auto logged in

Hope this resolves the issues for all.

The auto-login still is active for both ED variants :-(
 
Last edited:
RexKraemers solution did it for me, except the auto-login, which is still active.

I started the launcher from the directory, too and after selecting the normal E: D an upgrade showed up.
After that mysterious update the launcher is starting like before, even from the desktop shortcut.
Well... at least almost like before, you get auto logged in...

So, thanks to Mr. Rex "Danger seeker" Kraemer... (y)
 
Top Bottom