Both Zende megaships didn't jump!

EDIT: The Conduit is still in Zende after all. I wasn't on-board and It had just orbited so far away from my location in 30 minutes that I initially thought it was gone. Sorry for the confusion. It turns out that both ships didn't jump. It will be interesting to see the forthcoming Galnet news.

I was expecting "The Sandler's Song" megaship to take the place of "The Conduit" megaship after tonight's tick, but there's empty space where the Conduit was.

I was assuming that the two ships were swapping places.

Where is "The Sandler's Song" now?
 
Last edited:
I was outside "The Conduit" megaship and didn't board. It appears it jumped because there's no megaship where it was now.
Where did those who were aboard end up?
 
Last edited:
No. The Conduit is still in Zende after all. It had just orbited so far away from my location that I initially thought it was gone. Sorry for the confusion.

I wonder what Galnet story Frontier will cook up for this?
 
Last edited:
I was docked at Sandler's Song too and it's still where I left it yesterday. Only thing I noticed when I first logged in just now the Station Services were unavailable.
After a re-logging they were available again but now this appeared :
 
We are all doomed.
Seriously, nothing is expected to work from the first attempt. Especially in this rather complex product.
Will be fixed without doubts, have a patience, I guess)
o7
 
I’m also stuck in The Conduit/Zende...

And now let’s sing all together : “ We all live in a yellow submarine,yellow submarine,yellow submarine...
 
Top Bottom