Release Aussiedroid's Enhanced Thrustmaster Warthog Script

Well, first of all thanks for your reply @Clicker and @Aussiedroid.
I would like to try this to switch back to 4.0 but as there are so many different locations where to look who can I be sure that I have reset all locations.
Additionally I personally do not believe that it is an AD script issue as if I am pressing the buttons manually everyting works in normal speed without delays.
I the meantime I ordered 6 addional voices from HCS 50% off special offer last weekend and installed all voices and also the HCS tools again, but there were no changes to the commands delay behaviour.
But I will try your suggestion one after another and we will see as it works out. I will keep you posted.

Thank you both and kind regards,
major7079 aka CMDR E. P. Cole
 
Last edited:
Also, if you have not already done so...go take a look in the HCS Forums and join their discord @major7079

Also, one common remedy as mentioned on the discord is:-

Make sure that you have voice attack target dropdown set to "Active window"

Hope this helps.

Clicker
 
Last edited:
Also, if you have not already done so...go take a look in the HCS Forums and join their discord @major7079

Also, one common remedy as mentioned on the discord is:-

Make sure that you have voice attack target dropdwon set to "Active window"

Hope this helps.

Clicker
Hi Clicker,

Two minds, one thought. This was exactly my thought and indeed this target dropdown was set to "Elite Dangerous". So I have switched it immediately to "Active Window" but sorrily this was not the solution. The delay is still present and commands are not processed correctly via voice attack.

But thanks, anyway.

Now I will try out your and AD's suggestions as other mentioned forum and discord tips did not help either.

Kind regards,
major7079 aka CMDR E.P. Cole
 
Hi Klicker and AD,
I have got my problem fixed by Gangrel on HCS Discord channel.
I do not now but somehow my keyboard press settings *durantion were all changed.
Now as I have set them back all to 0.050sec in the Voice Attack Profiler everything worked as intended so far I could see on my first attemps out in the black.
Thanky you for your patience and support.
Take care and o7,
major7079 aka E.P. Cole
 
I promised to report back when I get it and...here I am....I fnally received the slew upgrade and fitted/exchanged it in the Warthog throttle:
https://www.reddit.com/r/hoggit/comments/bfh2fm Source: https://www.reddit.com/r/hoggit/comments/bfh2fm/ive_upgraded_my_tm_throttles_slew_control/


And...OMG...this is such a great upgrade! A missing good analouge mini-stick is the only weak spot the Warthog has...it has it no longer.
Replacing it took around 10 minutes, but I was rather overcautious. Remove 4 screws, unplug the old slew thingy, replace and ta-da.

WORTH
EVERY
PENNY!
:D
 
Looks like an awesome improvement over the original.

I am tempted although the cost (~53UKP = NZ$110+) plus a three month wait is a tad sobering.

I admit, due to the relative uselessness of the current slew stick, I do not use it for anything.
What function, in game do you use the slew joystick for?

Cheers
Clicker
 
‘Kit...just ordered one anyway!

@M. Grey , while you had your throttle apart, I dont suppose you noticed if you could swap the mike switch with slew switch?

If this is possible, I’d rather use my thumb for the slew control.

Clicker
 
Last edited:
Wise decision...you'll love it! ;)

Hmmm...did not rly look. I can check later since I swapped the slew switch and replaced one broken hat switch TM sent me. Can compare both if the seem same/similar.
If they have same dimensions and the "key" at same position it should work. Taking the throttle apart is very easy.
 
Last edited:
I promised to report back when I get it and...here I am....I fnally received the slew upgrade and fitted/exchanged it in the Warthog throttle:
https://www.reddit.com/r/hoggit/comments/bfh2fm Source: https://www.reddit.com/r/hoggit/comments/bfh2fm/ive_upgraded_my_tm_throttles_slew_control/


And...OMG...this is such a great upgrade! A missing good analouge mini-stick is the only weak spot the Warthog has...it has it no longer.
Replacing it took around 10 minutes, but I was rather overcautious. Remove 4 screws, unplug the old slew thingy, replace and ta-da.

WORTH
EVERY
PENNY!
:D
OMG, I replaced a defective slew sensor with an original spare part from Thrustmaster a couple of years back. It works, but is still pretty much unusable. As you said, it's the only weak spot on the Warthog. Ordered!
 
Since replacing the stick and re-calibration, my profile sometimes stops, the Warthog not working anymore. Have to restart TARGET, reconnect Stick & Throttle.
Sometimes it works all day without issues though.
Any ideas?

Update:
Disabled this for most USB controllers/input devices and USB Hubs in:
Device manager > USB controller/device/Hub >power management > allow the computer to turn off this device to save power
Seems to work so far, no bugging out...yet.
 
Last edited:
I promised to report back when I get it and...here I am....I fnally received the slew upgrade and fitted/exchanged it in the Warthog throttle:
https://www.reddit.com/r/hoggit/comments/bfh2fm Source: https://www.reddit.com/r/hoggit/comments/bfh2fm/ive_upgraded_my_tm_throttles_slew_control/


And...OMG...this is such a great upgrade! A missing good analouge mini-stick is the only weak spot the Warthog has...it has it no longer.
Replacing it took around 10 minutes, but I was rather overcautious. Remove 4 screws, unplug the old slew thingy, replace and ta-da.

WORTH
EVERY
PENNY!
:D
MATE! That looks awesome. Thanks for looping back and sharing your experience with it. Oh boy am I tempted even more now!


Since replacing the stick and re-calibration, my profile sometimes stops, the Warthog not working anymore. Have to restart TARGET, reconnect Stick & Throttle.
Sometimes it works all day without issues though.
Any ideas?

Update:
Disabled this for most USB controllers/input devices and USB Hubs in:


Seems to work so far, no bugging out...yet.
Oh no! Not sure what might be happening there. Is there a way to contact the seller? Just thinking if its something with the upgrade that he may have seen it or know a fix, outside of something obvious like a pinched wire or loose connection.

Cheers, AD
 
Yep, he answers and is active on:

About my issue...2nd day, around 8h flight time...the issue did no occur again. Very sure it was related to USB controllers/devices/hub being turned off for power saving.
Such a game changer, the new stick feels very good, very intuitive.
As said...
WORTH...EVERY...PENNY! :D

Update: Got to fly a lot on weekend, no more issues...seems the power saving was the reason.
 
Last edited:
For anyone interested...

After upgrading Windows 10 to version 1903, device analyzer now seems to work on my PC (I could never get it to work over the last 2.5 years or so).

NOTE: if you use vJoy for anything and have not upgraded yet, be warned...it'll break vJoy.

Clicker
 
Top Bottom