[1.10.1] Some Hot Keys Not Working

Click here to go to the first staff post in this thread.
Thread: Some Hot Keys Not Working

Results 1 to 6 of 6
  1. #1

    Some Hot Keys Not Working

    Severity
    Moderate

    Frequency
    All of the time (100% reproducible)

    Area of Game Affected
    Performance

    Description
    When trying to build the hot keys R, Z, and X do not work. I tried it in multiple parks and is a problem with all building and parks.

    Steps to Reproduce
    Open a park, try to place an item, press X or Z nothing happens. Try to edit the building by pressing R, nothing happens.

  2. #2
    Hi, tenniswhizsarah

    You have to lightly tap the Y and Z. If you just hold them down it looks like nothing is happening. Tap Y and Z fast as see if that solves your problem. I had the same issue when I first started and that was all I had to do. I Hope it helps.

    Heather

  3. Click here to go to the next staff post in this thread. #3
    Hey tenniswhizsarah,

    Thanks for the report.

    I've not been able to reproduce this issue on my end.

    Do you mean when you have building pieces on a grid selected?

    If you're in edit mode for a building you won't be able to rotate (z) or advanced move (x) the whole building until you select done.

    If you have a building piece on a grid selected while in edit mode, you'll need to select move (m) before rotate (z) will work.

    It is not possible to advanced move building pieces while in edit mode as they're on a grid.

    I hope I've understood this issue and offered some useful assistance. If you have any further questions or issue please do let us know.

  4. #4
    Originally Posted by QA-Mitch View Post (Source)
    Hey tenniswhizsarah,

    Thanks for the report.

    I've not been able to reproduce this issue on my end.

    Do you mean when you have building pieces on a grid selected?

    If you're in edit mode for a building you won't be able to rotate (z) or advanced move (x) the whole building until you select done.

    If you have a building piece on a grid selected while in edit mode, you'll need to select move (m) before rotate (z) will work.

    It is not possible to advanced move building pieces while in edit mode as they're on a grid.

    I hope I've understood this issue and offered some useful assistance. If you have any further questions or issue please do let us know.
    Whether in building edit mode or starting a new building with a single piece, I cannot rotate the piece at all as the Z key is seemingly non-functional. When placing a new scenery piece I cannot rotate it using Z or bring up the advanced move with X. When out of a building, after selecting the building I cannot enter edit mode by pressing the R key. And in addition T does not toggle the freelook camera. I've been playing this game since beta so I understand how building works, and these keys have always done what they should until yesterday.

  5. #5

    Issue Resolved Itself after Computer Restart

    After submitting my last response, I went in the game and tried it again and it was working. Really weird, maybe it just needed a restart. Thanks for looking into it. I'm glad I can play the game again

  6. This is the last staff post in this thread. #6
    Hey tenniswhizsarah,

    Glad to hear this is working again.

    If this causes any further issues please let me know. If you can get a video of the steps you take to make it happen that would be very helpful if any future testing is needed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not edit your posts
  • You may not post attachments