Game Unplayable since 1.9 due to GPU Crashes

Click here to go to the first staff post in this thread.
Thread: Game Unplayable since 1.9 due to GPU Crashes

Results 1 to 16 of 16
  1. #1

    Game Unplayable since 1.9 due to GPU Crashes

    THIS PROBLEM HAPPENS ONLY IN PLANET COASTER. All my other graphics-intensive games work just fine.

    Ever since 1.9.x came out, PC has been unplayable for me. About 90% of the times I try to play, my GPU crashes within 1-3 minutes of opening an existing or starting a new park. This actually started in 1.8 but I was able to fix it with a driver update and things were OK until 1.9. I have updated my driver twice since 1.9 came out and it hasn't helped.

    It happens like this (about 90% of the time---the rest of the time, everything works fine):

    1. Launch PC.
    2. Open an existing or start a new park. (IOW, it doesn't matter how many parts or peeps are in the park--this happens both with empty maps and full-map, highly decorated parks with 10K peeps in them).
    3. Pause the game as soon as the interface comes up.
    4. Start building stuff. Generally, I only have enough time to open the building or coaster editor and select, but usually not place, the 1st part or station.
    5. My screen goes black.

    The computer itself hasn't crashed and is still running along just fine. However, I cannot interact with it because my monitor is effectively turned off. Blind alt-tabbing out of PC doesn't help. Unplugging and replugging the monitor doesn't help. Thus, the only thing I can do is a hard reboot. When the computer reboots, the monitor works again.

    Sometimes, when I launch PC after one of these episodes, I get a message saying I had a GPU crash last time and asking if I want to turn on extra logging. Most of the time, I don't see this. I always say "yes" but I never see anything later on saying logs have been sent, or telling me were these logs are.

    I also have "-enableaftermath 1" in my lauch profile. I only found out about this a few days ago because I wasn't playing when that was announced last year. Since I put this in my launch profile, I have not been prompted to turn on extra logging due to previous GPU crashes. Also, since I put this in my launch profile, when my screen goes black, I hear the Windows ding that announces some sort of window has popped up. Because my screen is totally black, I can't see this new window at all, so I just assume that there's a "send logs" button active on it, so I hit ENTER in hopes it's sending in the data. Then I reboot.

    It would be VERY helpful if, after rebooting and launching PC again, I got a pop-up saying "Your GPU crashed last time. You had the extra logging on. Click here to send in the logs and tell us what was happening at the time of the crash."

    Anyway, here's my DxDiag: https://www.dropbox.com/s/6vhnr88j3c...xDiag.txt?dl=0
    -Bullethead
    (click here for Workshop page)
    NIHIL INIQVIVS QVAM ∆QVITATEM NIMIS INTENDERE

  2. Click here to go to the next staff post in this thread. #2
    Hi there

    I am so sorry to know that you have been experiencing this, it sounds very tedious!

    However, your assumption of submitting crash reports is correct! When you were hitting enter during your black screen you were submitting those for us, therefore that's great. As you have submitted these, we will then be able to look these up and hopefully get a better understanding as to why you are experiencing this issue.

    In order to look these up, I will require your Steam ID as this is how we navigate to specific crashes. However, I shan't ask for you to provide that for us here, instead, we would be in a much better situation to handle this case if you submit a ticket with us via the following link: https://support.frontier.co.uk/topic.php

    When you do, it would be super helpful if you could also attach your dxdiag so that we can refer to it.

    Hopefully, we will get to the bottom of this issue in no time!

    Thanks!
    Park Inspector Bubbles
    Frontier Customer Support Team

    Need some support? Visit our Support System here!

  3. #3
    Ticket submitted with DxDiag. Thanks for looking at this.
    -Bullethead
    (click here for Workshop page)
    NIHIL INIQVIVS QVAM ∆QVITATEM NIMIS INTENDERE

  4. #4
    Originally Posted by Bullethead View Post (Source)
    Ticket submitted with DxDiag. Thanks for looking at this.
    Hi,
    i have the same problems - game crash after 1-30 min - black screen

    I have send a few crash reports and also submitted my dxdiag via ticket

    greetings

  5. #5
    Does the black screen have a mouse arrow on it as well? You may be looking at an issue with part of Windows as well (Desktop Window Manager) which for some reason crashes occasionally lately (particularly on Windows 10).

    Shane

  6. #6
    Originally Posted by shaneturner12 View Post (Source)
    Does the black screen have a mouse arrow on it as well? You may be looking at an issue with part of Windows as well (Desktop Window Manager) which for some reason crashes occasionally lately (particularly on Windows 10).

    Shane
    hi,
    i try to explain

    The blackscreen has a mouse arrow,
    i have a 3 monitor setup, i play on one in fullscreen mode.

    When the game crashes i only can bring up the window with the crash - message in front when i choose it from the taskbar on a other monitor.

    Name:  crash1.png
Views: 132
Size:  23.2 KB

  7. #7
    Originally Posted by shaneturner12 View Post (Source)
    Does the black screen have a mouse arrow on it as well? You may be looking at an issue with part of Windows as well (Desktop Window Manager) which for some reason crashes occasionally lately (particularly on Windows 10).
    Nope, totally black, no mouse, no nothing. It's like the monitor has been turned off. I'm using Win7, too.

    Anyway, Frontier has been very helpful on this issue with daily emails ever since I turned in the ticket. Last time I played PC, it stayed running for a couple hours and I voluntarily and cleanly shut the game down for the 1st time in a long time. I still don't trust it completely yet, however, as this occasionally happened even when most of the time the screen would black out.

    Tinkering around with this turned up the following issues:

    1. I have some bad RAM. I just received the replacement modules and will have them installed either tonight or tomorrow. Windows has a built-in diagnostic that can check your RAM so you might want to use it.

    2. I had some corrupt Windows system files which I've replaced. Bring up the command prompt and type in "sfc /scannow" (without the quotes).

    3. I had some corrupt Nvidia driver files, which have also been fixed. When installing a driver, tell it Custom Installation and then just check the "Clean Install" box.

    Anyway, things definitely look much more hopeful than they did a week ago but I haven't had much chance to play PC since they improved, and I still need to change out my RAM. Hopefully I'll be able to give it a good test run this weekend and will report back.
    -Bullethead
    (click here for Workshop page)
    NIHIL INIQVIVS QVAM ∆QVITATEM NIMIS INTENDERE

  8. #8
    Hello,
    Frontier Support gave me some tips and at the end the following steps worked for me:

    + i made a clean reinstallation of my graphic drivers, deleted the old one with the "Display Driver Uninstaller"
    + uninstalled Planet Coaster and reinstall it
    + disabled the Steam overlay

    after that it looks like everything is running fine now, could play for more than a hour without crash

  9. #9
    Originally Posted by never1337 View Post (Source)
    Hello,
    Frontier Support gave me some tips and at the end the following steps worked for me:

    + i made a clean reinstallation of my graphic drivers, deleted the old one with the "Display Driver Uninstaller"
    + uninstalled Planet Coaster and reinstall it
    + disabled the Steam overlay

    after that it looks like everything is running fine now, could play for more than a hour without crash
    Thank you so much! Finally I found this solution afeter two weeks! I can play without crash

  10. #10
    How do I disable the Steam Overlay?

    Coaster Head Club Member, VIP, Early Bird

  11. #11
    Originally Posted by Spanky View Post (Source)
    How do I disable the Steam Overlay?
    Steam > Settings > In-Game / uncheck "Enable the Steam Overlay while in-game"

  12. #12
    Well, PC has been working well for me lately, since I went through various exercises with Frontier, even though I still haven't replaced my bad RAM. The new RAM I ordered didn't work so I put the old RAM back in. More new RAM arriving early next week.

    So, I'm back in business. Yay! Many kudos to Frontier support. Still, I have to ask, why was it ONLY PC that I had this problem with. Games using the Unity, Unreal, and every other engine except Cobra worked fine all through this. So I hope our exchange was mutually beneficial and Frontier found something they might be able to tweak.
    -Bullethead
    (click here for Workshop page)
    NIHIL INIQVIVS QVAM ∆QVITATEM NIMIS INTENDERE

  13. #13
    We had the same problems with the Cobra Engine in RCT3. Unfortunetely it's Frontier's very own engine, that's why they use it in their games. Don't know, if this engine was ever overworked for better results since RCt3 times.

    @cerealfruitcakes - thanks for the hint

    Coaster Head Club Member, VIP, Early Bird

  14. #14
    After I subcribed Toolkit-Objects from the Steamworkshop, nothing was loaded into the Game. I have starting my Computer, Steam und Planet Coaster many times again. No new Items from the steam workshop in the game, Toolkit-Items and other Stuff from the Workshop. I have started my Computer,Steam, PlanCo the third time again and now Planet Coaster doesnīt run. Only the Cobra-Screen for days, and nothing happenenend. This is since weeks.

    I have made this:

    + i made a clean reinstallation of my graphic drivers, deleted the old one with the "Display Driver Uninstaller"
    + uninstalled Planet Coaster and reinstall it
    + disabled the Steam overlay

    but nothing. The Game is unplayable.

  15. This is the last staff post in this thread. #15
    Sorry to hear that, please send us a ticket via: https://support.frontier.co.uk/kb/ with an attached dxdiag and we'll be happy to help @Terra

  16. #16
    Originally Posted by Spanky View Post (Source)
    We had the same problems with the Cobra Engine in RCT3. Unfortunetely it's Frontier's very own engine, that's why they use it in their games. Don't know, if this engine was ever overworked for better results since RCt3 times.

    @cerealfruitcakes - thanks for the hint
    It's been said and confirmed before that the current engine only carries the same name, but not the same architecture.....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not edit your posts
  • You may not post attachments