GPU running extremely hot

Thread: GPU running extremely hot

Results 1 to 12 of 12
  1. #1

    GPU running extremely hot

    Hi there, my gpu runs at an average of 75 degrees Celsius to 81 degrees Celsius. This should not be happening. I originally ran the game on high and then dialed the graphics down to medium and still have heat issues. My cpu runs pretty hot as a well. My system should in theory have no issues running Planet Coaster.
    I was wondering if anyone had tips to fix this problem.

    My cpu is: Intel(R) Core(TM) i7-7700k CPU @ 4.20GHz

    My gpu is: NVIDIA Geforce GTX 1080

    I have v sync enabled in game which helped the temperature of the gpu at first but now it seems like it does nothing.
    Also, it runs very hot even if I load in a blank map and place 1 flat ride or build 1 coaster.

    Any tips would be appreciated!

    Thanks!

  2. #2
    Those temps are a tiny bit higher than usual I guess but nothing to worry about, especially for a GPU.

  3. #3
    Never hurts to ensure you PC is dust free and you have proper ventilation. If you are really worried see if you have any open spots on your MOBO and fan slots in your tower. You can always add more fans. But as Chems said its a minor variance.

  4. #4
    The thing is, that the game seems not to be 100% compatible to all hardware. My GPU starts running at 99% the moment I start the game (talking about the main menu here, not starting a park).

  5. #5
    xyphic is offline
    Planet Coaster Security
    Volunteer Moderator

    Originally Posted by Ser_Optimus View Post (Source)
    The thing is, that the game seems not to be 100% compatible to all hardware. My GPU starts running at 99% the moment I start the game (talking about the main menu here, not starting a park).
    Do you have VSync turned on? When VSync is off, games will generally churn through frames as quickly as possible. If the scene is not computationally complex (such as in a menu) you'll often find that in these situations your GPU will be fully utilised.

    Basically: turn VSync on to limit your frame rate to your monitor's refresh rate and your GPU shouldn't have to work so hard.

  6. #6
    Originally Posted by xyphic View Post (Source)
    Do you have VSync turned on? When VSync is off, games will generally churn through frames as quickly as possible. If the scene is not computationally complex (such as in a menu) you'll often find that in these situations your GPU will be fully utilised.

    Basically: turn VSync on to limit your frame rate to your monitor's refresh rate and your GPU shouldn't have to work so hard.
    Yes, VSync is on, I always have it turned on, since I hate tearing..
    And I think I wrote that misunderstandable. I meant that the GPU roasting already starts in the menu. It won't stop when I start playing.

  7. #7
    xyphic is offline
    Planet Coaster Security
    Volunteer Moderator

    Originally Posted by Ser_Optimus View Post (Source)
    Yes, VSync is on, I always have it turned on, since I hate tearing..
    And I think I wrote that misunderstandable. I meant that the GPU roasting already starts in the menu. It won't stop when I start playing.
    Are you able to monitor the frame rate to make sure that the VSync setting is actually being taken? It'd be very odd for GPU to be fully utilised in the menu with VSync on.

  8. #8
    Originally Posted by xyphic View Post (Source)
    Are you able to monitor the frame rate to make sure that the VSync setting is actually being taken? It'd be very odd for GPU to be fully utilised in the menu with VSync on.
    So I played around with it a little more. In the menu I have stable 60 FPS with Vsync turned on or off, does not make a difference.
    After switching to windowed mode, which results in the game changing the resolution automaticaly when you change the size of the window, the GPU jumps around between 25 % when only using a quarter of the monitor at something around 600x450 pixels and 80 % at near-fullscreen at 1080p....

    But since the update yesterday it does not seem to reach the 99% mark anymore, so maybe it won't melt my baby after all

    I'll come back with an update after testing a bit further in-game maybe friday or at the weekend.

  9. #9
    Originally Posted by Ser_Optimus View Post (Source)
    The thing is, that the game seems not to be 100% compatible to all hardware. My GPU starts running at 99% the moment I start the game (talking about the main menu here, not starting a park).
    What GPU do you have?

  10. #10
    How about taking off the side panel, a temp (no pun intended) measure I know, but see if that helps, as I have an issue with heat, the CPU Fan (water cooler) would run at 100% (after 10mins of play) even though each of my 10 Cores reached no more 45C..................GPU 70C. It's probably just a settings issue in my case (again, no pun) but I don't know how to sort it.

    My ventilation mind is not great, my PC case is purely for aesthetics (in Win 805) but since I removed the side panel, the CPU fan as not kicked in once, games runs silent.

  11. #11
    Originally Posted by NoNameCity View Post (Source)
    How about taking off the side panel, a temp (no pun intended) measure I know, but see if that helps, as I have an issue with heat, the CPU Fan (water cooler) would run at 100% (after 10mins of play) even though each of my 10 Cores reached no more 45C..................GPU 70C. It's probably just a settings issue in my case (again, no pun) but I don't know how to sort it.

    My ventilation mind is not great, my PC case is purely for aesthetics (in Win 805) but since I removed the side panel, the CPU fan as not kicked in once, games runs silent.

    What gpu do you have?
    My 1080 just goes straight to 80C and i cant figure out why. My cpu likes to hover around 65-70C as well.
    I have vsync on and get 135-145 fps.

  12. #12
    I have the ASUS NVIDIA GTX TITAN X 12G.....it's a 2yr old card now, don't know how that compares to more recent cards, I'm happy enough with it.

    If it helps, I have the Intel i7-6950X 3.00GHz....I don't overclock....idle...CPU runs on average at 25/28C...GPU......35C

    I have never seen fps of 135-145......I get 30/40.....all settings at Max......I have the Dell P2715Q 4K

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not edit your posts
  • You may not post attachments